Baby Fleming Public Shared Section

Looks like the same error I’m having.

1 Like

Agreed and I apologise for my rant. Unreservedly

Yes I agree it would be good to have a record of system/network charges. And as importantly that list can be purged (say allow user to deleted anything older than some time, eg delete anything older than 1 week)

3 Likes

In these troubled times a good rant can be therapeutic.
Luckily in this case, I don’t think the the rantees were too bothered, they already had it covered :slight_smile:

4 Likes

It may be essential to have such a record. I’m tinking perhaps of a situation where a company is perhaps creating accounts or wallets on behalf of users or indeed for its internal uses and would need a record of that expenditure. Or am I talking pish? It is late here.

Who mentioned Folding At Home and GPUs? I have been fighting with apt get and dpkg about unmet bloody dependencies for the past two hours…

2 Likes

Sometimes struggling with unmet dependencies can be theraputic. Not very often though.

4 Likes

UPDATE today (1st April) we have released a new Alpha version of the SAFE Browser (Desktop) which works with the new shared section, or indeed your local sections that you may be running. You can download the new Browser here.

The OP has been updated to include this.

PS no, this is not an April fools joke :wink:

Note that I’ve only tested this new browser on macOS so far, happy path tests seem fine so I’ve released it for Linux, Windows & macOS, and I’ll test the other 2 platforms now - if you come across any issues do let us know!

We are working on making other apps compatible, such as the SAFE Network App, the mobile Authenticator and the mobile Browser. These should follow in due course

24 Likes

Even after a warning many may mistake 1 nano difference as a rounding error it has been such a common design flaw for too many decades. Increasing the default fee to a whopping 5 nano would be much harder to mistake as a rounding error.

Besides “5 nanos ought to be enough for anybody”.

6 Likes

thanks for link! Any available site ATM?

1 Like

I’ve thrown up a basic site safe://animals for some testing I was doing - I’m sure others will post their sites before long

6 Likes

Not in this case, I was up until 5 and I’m on the laptop now…
Desktop still won’t boot again.
Time to stick a USB recovery stick in it and clean up…

Just when I wanted to play with the new browser too…

safe://network
safe://maidsafe

Are up :slight_smile:

9 Likes

@JPL @happybeing not sure if you are both on Windows, but I see JPL definitely is so I’ve been using a W10 VM and created an account successfully.

One thing which I did see was that the Git Bash terminal I originally tried with was acting up - when I tried safe auth create-acc --test-coins the prompt for the passphrase & password just never appeared. I switched to Cygwin64 terminal and it worked fine. Doesn’t sound related to what you are seeing, probably just my VM, but worth a shot in a different terminal if you are using Git Bash…just in case that is an issue

1 Like

I’m on Ubuntu 19.10 and have tried a few things (restarting authd etc) but always fails to bootstrap. More here:

I haven’t tried today so will do so now and add the outcome here.

2 Likes

On the off chance that you have an old, rogue, auth process running, could you run safe auth stop a couple of times - until it errors because there are no auth processes running.
Make sure nothing safe exists in your ~/bin any more (or anywhere else in your PATH other than .safe), in case that is causing some sort of mix up.
Then run safe auth start.
Confirm with safe auth status that it is 0.0.7 running - maybe check your processes and confirm there is only 1 auth process running.
Once that’s done try creating an account again

2 Likes

Baby’s first steps…

12 Likes

Have tried on Powershell and cmd with the same result. With Git Bash (same as MinGW?) I get the same behaviour you note, but I don’t normally use Git Bash.

One thing to note that may be relevant. safe auth stop and safe auth restart don’t work. This occurs whatever the terminal:

John@John-HP MINGW64 /c/users/John/Documents/SAFEnetwork/_safe-cli
$ ./safe auth stop
[2020-04-01T14:04:47Z ERROR safe] safe-cli error: [Error] AuthdError - Failed when invoking safe-authd executable from 'C:\Users\John\.safe\authd\safe-authd.exe':

safe auth start does work.

1 Like

@StephenC @JPL from what i see in JPL’s screenshot CLI is not even trying to use authd at that point, CLI first creates the test-coins directly to the network, and that’s the step is failing there, once the test-coins are created CLI will send the request to authd to create the account using those test-coins. So it seems you are having issue to connect to the network, can you please try safe keys create --test-coins, that should fail if you still have issue to bootstrap.

Edit: a firewall issue perhaps? can you also see what kind of info you get doing RUST_LOG=debug safe keys create --test-coins ? that should help us probably understand why it cannot bootstrap

2 Likes

Awesome achievement with the publicly hosted section! Great job!

I ran the CLI commands and were able to connect and upload an image file. However since the current version of the SAFE Browser I can’t get it running. All previous versions worked without any problems. Here is what I did (Win10 64):

  1. Deinstalled the old browser version
  2. Installed the new version with administration rights
  3. Connected to the shared section network
  4. Ran the new version with administration rights
  5. The process (actually it displays 3 processes) seems to start, but no browser window opens

The same behavior happens when I try to start the browser without a running auth service. So the problem seems independent to the vault network connection. Does the browser create any log files? I couldn’t find any. Anyone else running in this issue?

@Mindphreaker I’m not fully sure, but running it as admin perhaps is causing issues to the browser not being able to connect to authd as it probably cannot find authd QUIC certificates. Is there any reason why you run it as admin? can you try running everything as a regular (and same) user?

Not sure whether this is causing @Mindphreaker’s problem but I’ve just noticed there’s an issue with the signature of the browser exe for Windows - investigating

1 Like