Baby Fleming Public Shared Section

Had the same issue but after a few restarts/reboots it works (update from 0.0.5).

1 Like

Is that a chopper?

I’ll get my coat…

No, it’s electrifying…like Safenetwork! :grinning:

5 Likes

I can’t bootstrap from another Windows PC or a Linux PC either. Could it be my router?

Hmm… consistently unable to log in to shared-vault

willie@gagarin:~/.safe/vault/baby-fleming-vaults$ safe -V
safe-cli 0.11.0
willie@gagarin:~/.safe/vault/baby-fleming-vaults$ safe auth login --self-auth
Passphrase: 
Password: 
Sending login action request to authd...
[2020-04-03T01:36:30Z ERROR safe] safe-cli error: [Error] AuthdClientError - [Error] ClientError - Failed to read response bytes: read error
willie@gagarin:~/.safe/vault/baby-fleming-vaults$ safe auth status
Sending request to authd to obtain a status report...
+------------------------------------------+-------+
| SAFE Authenticator status                |       |
+------------------------------------------+-------+
| Authenticator daemon version             | 0.0.7 |
+------------------------------------------+-------+
| Logged in to a SAFE account?             | No    |
+------------------------------------------+-------+
| Number of pending authorisation requests | 0     |
+------------------------------------------+-------+
| Number of notifications subscribers      | 0     |
+------------------------------------------+-------+

I’m working on enhancing this error message, but what’s happening when you see this is authd taking too long (and for sure timing out) to connect to the network. So there seems to be a connectivity problem of authd with the shared-section.

3 Likes

This morning I had to re-authenticate and restart the SafeBrowser and the image is perfect…after a page refresh it’s scrambled again.

2 Likes

Not me. The images display show erratic behavior. Same in one of my pages.

Could be the Browser or the problem is deeper.

1 Like

FYI I’m using mobile broadband via a hotspot on my phone and have always seen either the bootstrap or read error messages when trying to log in and self auth.

I did see account logged in once, using safe auth status but not since, although I’ve not retried that much.

1 Like

It Just Works with the new mobile authenticator and browser except for one wee snag. The application stops unless it is kept on top.

@Yerontour nice bike image is untorn for me but on mobile is squeezed or stretched depending on portrait or landscape orientation

@davidpbrown I see what you mean about safe://hello22 and 23

1 Like

SOLVED: had to sync the whole folder

I update my .html(height=“auto” width=“100%”) and sync via the CLI but looks like the Safe version is not updated.

files sync /…/SafeSite/index.html safe://hnyynys5zcpbwm6jw7pio4fwe7ug6kr65yift6akgrkesr69crffjw3czwbnc
FilesContainer synced up (version 1): “safe://hnyynys5zcpbwm6jw7pio4fwe7ug6kr65yift6akgrkesr69crffjw3czwbnc?v=1”

  • /…/SafeSite/index.html safe://hbhybyntxwwru45n5wcknpxi6fw4medfws6o5a4rj4qptbu4iocdmg8hri
3 Likes

Still an issue with width=“100% scaling, that doesn’t work.

3 Likes

Yeah, I think you are having some intermittent connectivity issue with the shared-section, from what I see, sometimes from authd but sometimes from CLI. I’ll be making the CLI timeout window (in the comm with authd) larger also so it doesn’t timeout before authd times out, in this way we’ll be able to see the error coming from authd when it times out.

6 Likes

have a same problem!

What does this suggest?

ERROR safe] safe-cli error: Failed to connect: [Error] InvalidInput - Failed to decode the credentials: InvalidMsg

I’m getting that with cat; dog; files ls …?

That’s because you are using credentials which you probably obtained for a different network…?, to solve it just make sure you re-authorise the CLI. I’ll check why is requiring them though, as it shouldn’t need them for read-only commands like cat on public data.

Edit: you can also fix it by removing the credentials file from ~/.local/share/safe-cli/credentials, then you should be able to have read-only access to public data. I’ll enhance it so it doesn’t fail when the credentials are invalid and not necessary like in the case of cat/dog on public data.

2 Likes

Removing that file worked but I noted that file was zero bytes empty.

1 Like

Before you do, perhaps consider the cat dumps error as it its content…
see

If ever there is an error, that should not become part of the content that cat is generating… :thinking:

2 Likes

So, I downloaded @Yerontour bike index.html and jpg… fixing the cat for getting the real image… and that works in firefox but uploading I got a similar problem to above… which I wonder is the same that is corrupting the eye.eye .gif

So, given the image downloads (tail -n +2 ./zero.jpg > ./zero1.jpg removed the error).
It seems this necessarily then is a browser issue… the file is uploading and downloading as it should … ??

1 Like

I’m having the issue where the bootstrapping times out. Anyone got an idea for what to do?

EDIT:
I got it to work by doing safe auth stop, then safe auth start and then safe auth create-acc --test-coins.

@happybeing pinging you to see what worked for me.

3 Likes