A vault in my home


#13

I guess the IP address is your computer’s internal IP. If you bring up a command prompt and type ipconfig you should be able to see the IPv4 address which is the one you want. Regarding Windows firewall I usually just get a little pop-up when I start a vault for the first time asking me to agree to whitelist it, but I think I have admin rights (I get a bit confused with how it works in Windows).
Ah @remco beat me to it!


#14

I agree 100% There is no interface, Im opening and running it, no idea WTF is happening I just see new node text files being created.


#15

I believe once NAT Traversal is re-enabled in Crust, connections will all be automatic and under the hood, so no tinkering with port forwarding or UPnP


#16

Well if up speed needs to be 6mbps good luck to anyone in Australia we have some of the worst upload speeds on the planet. I am currently on an ADSL line with a max upload of 0.8. I’d have to wait for the NBN rollout which is not till Jan 2018 in my area, sign up for an NBN connection which I am told has heaps of problems already and even then i’d only get about 4mbps so i’d have to pay for a speed boost to get about 40mbps


#17

Join the club :angry: Although you are earlier than me.

There is a least one other person on the forum who has the 40Mbit/sec upload and they say that getting near that is possible. So I live in hope.

The 6Mbits/sec requirement should be coming down as things/tests progress and they can see the network working fine with the lower limit. Its almost a case of its so high so they can guarantee good performance with so few nodes. As the node count dramatically increases then the effects of slower nodes reduces somewhat. More nodes allows the lower limit of upload speed to reduce.

There is still going to be a limit of some amount. Imagine 1000 nodes on a 1Mbit/sec upload, all the GETs from that lot of nodes will potentially take hours to upload. Not a very useful network and of course those vaults would rarely ever get a coin


#18

We have set aggressive “magic numbers” here to remove a limitation. The network will set this number eventually. This will be much lower than we have set but will disallow some nodes I am sure. Anyway, I am also on adsl so will be pushing this as low as we can while we do the tests. tests will always err on side of requiring much more than needed and also we will be allowing much slower nodes, but of course they will be limited in farming ability for sure, but that’s all Ok for me anyway.


#19

have you heard of this? https://www.lightningbroadband.com.au/


#20

OK Makes sense. Thanks


#21

No

Having a look at it, they also are only offering up to 100Mbits/sec download. If you are willing to pay for it, as you will with them too, you can get fibre from other companies too, especially if you live in the cities and their inner suburbs. TPG used to do it before NBN as did Telstra and some other mainly business ISPs. TPG bought out the major fibre supplier and are still supplying fibre to businesses and interconnects.

But nice to have symmetrical fibre. Wonder what their international peering is like, hopefully not the bottleneck Optus suffers.

EDIT: From their website for the home connections

So its not fibre to the home as they implied on their front page.


#22

I’m using win10. If I type ipconfig in the terminal I get two ip addresses: one for ‘Ethernet adapter ethernet’, and another for ‘Wireless LAN adapter wi-fi’. I’ve tried both (and tried the gateway ip) but no connection still.


#23

If your internet is over wifi it’s the wireless one, if it’s cable it’s the Ethernet one. What happens when you try to connect? What does the log say? (The logs are in the same folder as safe_vault.exe, named node..log)


How to set up a vault from home
#24

After @JPL walkthrough for BT router, here is my small contribution for Orange Livebox in France:

Go to 192.168.1.1. Connect to the admin account. Select “configuration avancée” general tab and then “NAT/PAT” sub-tab. Then enter a new rule for port forwarding:

  • Select “nouveau…” in “application/service” drop down menu and then enter any name (for example: SAFE Network)

  • Enter 5483 in both “port interne” and “port externe” fields

  • Select TCP protocol (it is the default choice)

  • Select the name of the PC which will run your vault in “appareil” drop down menu

  • Validate by clicking on “enregistrer” button


#25

If I run the safe_vault.exe in the cmd terminal I get this message:

Running safe_vault v0.14.0

E 17-04-08 14:27:00.204058 Failed to Bootstrap: (FailedExternalReachability) Bootstrappee node could not establish connection to us.
I 17-04-08 14:27:00.217088 Bootstrapping(5d8fd0…) Failed to bootstrap. Terminating.


#26

That means it’s not connecting. OK - if you’re not running a VPN or a proxy then your firewall or something else like antivirus software is probably blocking it. This is where it gets a bit tricky.

First thing to try is to edit the configuration file safe_vault.crust.config, changing “force_acceptor_port_in_ext_ep”: false to true.

If teat doesn’t work, the next thing is to try changing the Windows firewall setting - you’ll need admin rights for that - and then try disabling your AV software and anything else that might be blocking it.

Other than that all you can do as far as I know is try connecting a few more times as it doesn’t always work first time, maybe leaving a few hours between attempts.


#27

No need to wait a few hours, wait a few seconds and try again.
I would actually advise, trying 4-5 times before messing with settings.
Keep it simple. Once you start changing settings, you MUST change them back before changing anything else. UNLESS you really know what you are doing. Otherwise its too easy to take an almost working setup and reduce it to a pile of <insert smelly phrase here>


#28

It was the firewall, even though I had granted safe_vault.exe access. After fixing the port forwarding and shutting down the firewall I can finally connect. Now I need to find out how to allow connection for the safevault with the firewall on. Thanks for the help @JPL and others.


#29

A wee demonstration that sometimes you have to try , try and try again to get connected,


#30

Thanks for all the replies. I will go through all this tonight. I still feel this information should be put out on an official maidsafe page, but i am pretty lenient as i know there are way more important things to work on. I am assuming that in the future this will be seamlessly integrated.


#31

Hi there. I ran the test and only got 2mbps for my upload speed. So at the moment - in Dragon’s Den style - I’m out!

i was recently looking for online servers for Java hosting like Openshift. Does something exist for this new technology like that?


#32

What hardware that you are using ?
I’m considering to deploy my D-Link NAS for the Vault.